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Practice 4
Application of serial port to implement 

communications via UART
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Needed during practice
▪ 01_EFM32_User_guide_efm32gg-stk3700-

user_guide.pdf

▪ 02_EFM32_Schematic_EFM32GG-BRD2200A-A03-
schematic.pdf

▪ 03_EFM32_Reference_manual_EFM32GG-
reference_manual.pdf

▪ 04_EFM32_Datasheet_efm32gg990_datasheet.pdf

▪ Terminal program

Difference between ref. manual and datasheet/user guide:

-Reference manual contains general info of the whole IC family

-Datasheet/user guide contains specific info of a certain type of IC 

(from the IC family)
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UART / USRT / USART

▪ UART or USRT or USART?

o UART: Universal Asynchronous Receiver/Transmitter

• Serial communication without application of CLK line

o USRT: Universal Synchronous Receiver/Transmitter

• Serial communication based on CLK signal

o USART: Universal Synchronous Asynchronous 
Receiver/Transmitter

• Since the operation is very similar (main difference is the CLK 
signal) sometimes both are discussed without distinction
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UART properties

▪ No CLK signal, i.e., CLK line not needed->less wire

▪ 2 data lines: transmitter (Tx) and receiver (Rx) line

▪ Communication speed (=bit duration) has to be 
set -> defines the bit borders in the system

o Reference oscillators at both the Tx and Rx sides has to 
be precise otherwise frequency difference will occur 
between Tx and Rx side and bit duration will change

o If CLK existed it would define the bit borders (as done 
in USRT)
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UART Communications
▪ Start of communications: edge change from H->L for 

1 bit duration

o Start of frame bit (Start bit)

o Used for synchronization

▪ Data bits: from 4 up to 16 data bits

▪ Parity bit (P): optional

o Used for error detection -> error is not corrected

o Even parity: count of 1-bits is even -> P=0, otherwise P=1

o Odd parity:  count of 1-bits is odd -> P=0, otherwise P=1

▪ End of communications: edge change from L -> H

START Bit
(High-> Low)

Data Bit

Bit border 
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UART Communications
▪ End of communications: line is High for 1 or 1.5 or 

2 bit duration

▪ Full frame:

Refer to page 451 of 03_EFM32_Reference_manual_EFM32GG-reference_manual.pdf 
(Full USART: pp. 449-495)

STOP Bit
(High)

Data Bit

Parity Bit
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UART connection

▪ Checking the user-guide (for IC specific info) is a 
must -> see page 13. (of the old version)
-------------------------------------------------------------------

Refer to page 13 of 01_06_EFM32_User_guide_efm32gg-stk3700-user_guide_older.pdf
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UART connection

▪ Also see page 14. (of the old version)

-------------------------------------------------------------------

Refer to page 14 of 01_06_EFM32_User_guide_efm32gg-stk3700-user_guide_older.pdf
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UART connection on uC

▪ Checking the schematic 
-------------------------------------------------------------------

Port E (PE) connections:

Port F (PF) connections:

Enabling UART:
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UART connection – Board Controller
Board Controller:
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UART connection – Board Controller
Board Controller:



© BME-MIT 12.slide

UART connection – USB PHY

USB:

PC via USB cable
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UART connection – Block diagram
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Strating with a new project

▪ File->New->Project->Silicon Labs MCU Project:
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Strating with a new project

▪ File->New->Project->Silicon Labs MCU Project:
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Strating with a new project

▪ Give project name and location, and set 
Copy content:
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Project created – start programming

▪ Main.c can be also renamed to UART_COM.c

▪ Although an empty C project has been created a 
program skeleton is offered automaticly
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CLK for GPIO peripheral (CMU system)

▪ Every peripheral has and needs a CLK to operate

Refer to page 128 of 
03_EFM32_Reference_manual_EFM32GG-reference_manual.pdf
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CLK for GPIO peripheral

▪ CLK for GPIO peripheral must be enabled

▪ Search the library where Simplicity Studio is 
installed

o Contains include (inc: *.h) and source (src: *.c) files:
i:\Simplicity_studio\developer\sdks\gecko_sdk_suite\v2.6\platform\emlib\

▪ Following files has to be drag-and-dropped into 
emlib library of the project (see next slide):

o em_cmu.c (clock management unit)

o em_gpio.c

o em_usart.c
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CLK for GPIO peripheral

▪ Furthermore they have to be included into the 
program:

▪ Check how the CLK for GPIO can be enabled:
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CLK for GPIO peripheral (check .h files)

▪ In programming window click on
em_device.h and press F3 -> em_device.h opens

▪ Defines for different processors from EFM32 
family are found -> search for your own type 
(EFM32GG990F1024):
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CLK for GPIO peripheral (check .h files)

▪ Click on EFM32GG990F1024.h and press F3

▪ EFM32GG990F1024.h contains (among others)

o IT number that belongs to a certain peripheral

oMemory addresses, e.g. base addresses

• No need to check reference manual for e.g. base addresses
– Refer to page 17 of 

03_EFM32_Reference_manual_EFM32GG-reference_manual.pdf 
to see base addresses
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CLK for GPIO peripheral (check .h files)

o Defines types that are pointers for the base address

• Click on (CMU_TypeDef *) and press F3
– Type definition of CMU pops-up in efm32gg_cmu.h which is a 

structure

– Elegant solution

typedef struct {

__IOM uint32_t CTRL;

__IOM uint32_t HFCORECLKDIV;

.

.

.

} CMU_TypeDef;

Elements of structure is assigned to the memory registers via base-address pointer!
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CLK for GPIO peripheral (check .h files)
In the header file: In the RM see p.136  (03_EFM32_Reference_manual_EFM32GG-reference_manual.pdf):
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CLK for GPIO peripheral

▪ Using the structure CMU

o CMU is a structure pointer: arrow is used ->

o CMU-> (Ctrl+Space will complement) 

• Needed: HFPERCLKEN0  (Bit 13 is used for GPIO CLK)

• A define is available for Bit 13 in efm32gg_cmu.h 

See ref.man. P150:
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CLK for GPIO peripheral (CMU system)
▪ Every peripheral has and needs a CLK to operate

▪ Code to be used:

o CMU->HFPERCLKEN0 |= CMU_HFPERCLKEN0_GPIO;

Refer to page 128 of 
03_EFM32_Reference_manual_EFM32GG-reference_manual.pdf
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Setting GPIO in code (enable)

▪ Remember: PF7=1 has to be set

▪ More elegant approach if a function can be found 
for a problem -> Results in more readable code

o Check functions under em_gpio.c in the project
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Setting GPIO in code (enable)

▪ Open (double click on) GPIO_PinModeSet

o em_gpio.c opens at the function implementation

o Remark: em_gpio.h also contains the definition of 
functions and even more, e.g. static functions available 
only in header files

o Note: these functions are independent of the type of 
processor, since the processor dependent specialities
are defined in efm32gg_xxx.h

• Helps to develop portable code that is compatible with other 
processors (from the same processor family at least) 

o Hint: copy the function and paste it into code; make it 
one-line; comment the orig. and make a work copy
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Setting GPIO in code (enable)

▪ Read the function description: placed above the 
function definition
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Setting GPIO in code (enable)

▪ Function to be used:

o GPIO_Port_TypeDef + F3

Use the names given in 
the enum type definition
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Setting GPIO in code (enable)

▪ Function to be used:

o pin – port number, now it is 7

• No specific name is given

o GPIO_Mode_TypeDef + F3

o out – initial value of pin, use 1
Use the names given in 

the enum type definition
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Setting the UART (CLK)
▪ CLK is needed again! 

o Already used approach is also possible: setting CMU 
register

o Better way is using a function for that purpose

• Check em_cmu.c in the project by unfolding it:

• Find CMU_ClockEnable among functions

• Copy the function and paste it into the code:

– enable – it should be true obviously

– CMU_Clock_TypeDef + F3

» cmuClock_UART0 should be used

o Code to be used: 
CMU_ClockEnable(cmuClock_UART0, true);

CMU_ClockEnable(CMU_Clock_TypeDef clock, bool enable);
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Setting the UART (Tx and Rx)
▪ Remember: port settings for communications

o PE0 = Tx -> PE0 is output

o PE1 = Rx -> PE1 is input

▪ Use the function GPIO_PinModeSet again

o GPIO_PinModeSet(gpioPortF,7,gpioModePushPull,1);

• Used for setting PF7 into 1 to enable the UART comm.

o GPIO_PinModeSet(gpioPortE,0,gpioModePushPull,1);

• See changes in red for setting Tx line (PE0 is now output)

o GPIO_PinModeSet(gpioPortE,1,gpioModeInput,1);

• See changes in red for setting Rx line (PE1 is now input)

Delete back until gpioMode, then push F3 This boolean is don’t care now
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Configuration of the UART
▪ Check em_usart.c in project explorer

o Find USART_InitAsync and double click

• em_usart.c opens at the function implement.

• Read description of the function

• Copy the function and paste it into the code
– USART_InitAsync(USART_TypeDef *usart, const USART_InitAsync_TypeDef *init)

▪ USART_InitAsync()

o USART_TypeDef + F3 : it is a structure again defined in 
efm32gg_usart.h

• Remember that a pointer is used here!
– check out for its define in efm32gg990F1024.h



© BME-MIT 35.slide

Configuration of the UART
– Define of USART_TypeDef in efm32gg990F1024.h

– More than only one USART is available: USART0 is our choice 
(& is not needed since it is a pointer: see later)

o USART_InitAsync_TypeDef + F3

• Important parameters for the USART

• Unfortunately this structure is not existing, therefore it has 
to be implemented 
– implementation is advised before the main function in the .c main 

file as a global variable. In this case its initial value becomes zero 
(while when implementation is done inside the main function it fills 
up the structure with memory garbage)

– USART_InitAsync_TypeDef UART0_init;

• Not UART0_init is used but a memory address: &UART0_init

It can be any name
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Configuration of the UART
• Function to be used in the code: 

USART_InitAsync(UART0, &UART0_init);

• UART0_init structure has to be uploaded with values
– USART_InitAsync_TypeDef + F3 again -> em_usart.h

» Stay above the writing and options pop-up

– Code to be used: UART0_init.enable = usartEnable;
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Configuration of the UART
• Same way all the other properties has to be filled up

• Initialization has to be done before using it

• Note: every name has to checked! 
-> e.g. usartDatabits8 is not equal value 8 but value 5
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Configuration of the UART
o Oversampling: see ref.man. page 458:
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Configuration of the UART

▪ The faster way

o Look for the USART_InitAsync_TypeDef structure (F3) 
and scroll down in em_usart.h to find it

• It is a predefined default structure 

• Before the main function it can be used for initialization:
USART_InitAsync_TypeDef UART0_init = USART_INITASYNC_DEFAULT;
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Configuration of the UART
▪ Interesting difficulty with PE0 and PE1 pins

o Check datasheet on page 65.

o U0_RX and U0_TX default locations are PF7 and PF6, 
respectively, that has to be changed since the circuit  
(i.e. the board) has been designed for UART 
communication at Location 1

• Datasheet is valid for the IC not for the board but a freedom 
is given this way for the board designer

o Location 1 has to be set for correct operation
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Configuration of the UART
▪ Check reference manual at page 492
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Configuration of the UART
▪ Check reference manual at page 492
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Configuration of the UART
▪ Setting the I/O Routing register (i) for LOC1 (PE0 

and PE1 pins for UART communication) and 
enabling these lines for transmission and 
reception of serial data
o UART0->ROUTE |= (1) << 8;

• Although correct but not too informative

o A definition can be used for this purpose in 
efm32gg_usart.h (search for ‘LOC1’)
• #define USART_ROUTE_LOCATION_LOC1

(_USART_ROUTE_LOCATION_LOC1 << 8)

o UART0->ROUTE |= USART_ROUTE_LOCATION_LOC1;
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Configuration of the UART
▪ Enabling RX and TX via RXPEN and TXPEN bits 

respectively

o A definition can be used for this purpose in 
efm32gg_usart.h (search for ‘RXPEN’ and ‘TXPEN’)
• UART0->ROUTE |=(USART_ROUTE_RXPEN | USART_ROUTE_TXPEN);

▪ Everything is ready for sending data via UART
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Sending data via UART
▪ In Project Explorer window under 

emlib -> em_usart.c you can find
o USART_Tx(USART_TypeDef *usart, uint8_t data)

▪ Code to be inserted:
o USART_Tx(UART0, '+');

oWe send ‘+’ signal via UART0

o Good idea to check the compilation

▪ Where is the UART (COMx)?

o Check in Windows Device Manager
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Sending data via UART
▪ Check UART (COM port number and its settings) in 

Device Manager in Windows (now it is COM4)
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Sending data via UART
▪ A PC-based terminal program is needed to get 

access to COM4 port: an option is putty.exe

1

2 3

4

5

6
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Sending data via UART
▪ The terminal is now open

▪ Compile and download the code to check 
operation

o Has the ‘+’ sign appeared in the terminal window?
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Sending data via UART
▪ This status is the starting point to develop an 

UART communication-based application

o E.g. write in the terminal window the character sent 
via the keyboard (= read a character from UART0 and 
send this character to UART0)

• This function has to be added into the program (in the while 
loop)

• USART_Tx(UART0, USART_Rx(UART0));

o Problem: character is received in a blocking way:

• We are always in the loop waiting for data and no other 
operation can be done

• Better if the arrival of new data can be indicated not to stack 
in the while loop forever (non-blocking solution)



© BME-MIT 50.slide

Appendix:program code(a working version) 


